Question

😿‼️ Error fetching offerings - PurchasesError(code=ConfigurationError, underlyingErrorMessage=There's a problem with your configuration. None of the products registered in the RevenueCat dashboard could be fetched from the Play Store.

  • 15 April 2023
  • 2 replies
  • 654 views

Badge +2

So I had this error message on my Android testing of my Flutter app (iOS worked like a champ) and worked through the troubleshooting steps provided by RevenueCat support, (https://community.revenuecat.com/sdks-51/why-are-offerings-or-products-empty-124), (BTW some of these screens need updating please, particularly because this is a popular post), I even got Google Play Store support involved (the portal is soooo convoluted) and after about two weeks of getting one email response per day, at my wits end, I engaged the chat service. A chat support person in Google told me in five minutes that I could only make my app release ‘ACTIVE’ in the Closed Testing if … my Managed Publishing state was ON!

I didn’t know what that was, then they explained:

them: Kindly go to your app's Publishing Overview section on you Play Consoleme: kthem: Then, click the "Turn off Managed Publishing" button.them: Once you've turned it off, kindly wait for the changes to be reflected on your Play Console.

and then, That. Was. It.

Immediately my release was Active, and after about 2 hours, my subscription objects appeared in the app. 


2 replies

Userlevel 4
Badge +8

Huh, interesting. Thanks for the suggestion, Peter!

 

I’ll add this to our documentation as a troubleshooting step. I’ll also update some of the screenshots in that post.

Badge +2

Oops. Just noticed, I had the original post backwards. The reason I couldn’t get ‘Active’ is because my managed publishing state was on. I needed to turn it off.

Reply