Question

Subscriptions not working in Testflight (macOS)

  • 6 January 2023
  • 1 reply
  • 26 views

Badge

Hi all,

I'm building a macOS app with some renewable subscriptions.
Everything is working fine when testing within Xcode on my mac, but now I have uploaded my macOS app to TestFlight, I see that the offerings are not working.
If I inspect my network traffic with Proxyman, I do see that the app is trying to get the data, but the response is empty (or it says "invalid json").

Any idea what might causing this?

Kind regards,
Frederik
 


1 reply

Userlevel 4
Badge +9

Hey Frederik,

 

I see that the status code is 304 not modified. This is a performance optimization that the SDK does. It sends a cache value to our backend, and if nothing has changed the backend returns a 304, meaning that the SDK should use whatever value it has cached. So there shouldn’t be any received JSON here. I’m not sure how Proxyman works but hopefully that helps make sense of what’s happening. If you want to test without a cached value:

  1. Try updating the user in RevenueCat to trigger an invalidation of our cache. You can do this by adding or updating a subscriber attribute for example.
  2. Call invalidateCustomerInfoCache while testing. Although if nothing changed on RevenueCat’s end you may need to update the user as explained above.

About the app not working on Testflight: can you try going through this guide? You may just need to fix your configuration of products to get things working.

Reply