Subscription works in testflight, not production. IAP approved for over 48 hours.


Userlevel 1
Badge +6

I am unable to load an IAP/subscription after it has been approved for over 48 hours.
 

Left a comment on an older post, but wanted to make a second thread for visibility. (Hope that’s cool) If I run the app on simulator, a local device, or test flight everything loads perfect.

  • Subscription has been approved for over 48 hours.
  • Subscription loads fine on local/testflight.
  • Filled out all agreements.

App is in pending developer release. I downloaded the app from the app store with a generated code, and in app purchases do not work.

I ran the production app and plugged my phone in to view the console. Still getting “Could not find SkProduct for ( “my_product_name”) There is a problem with your configuration”, but only in production. “my_product_name” is not in the actual log, I did not include my real product name.

 

I was wondering if there is anything I could still be missing, or do I need to wait longer? The in app purchase was approved on Saturday at 11 AM. It is not Monday, 6:45 PM.

Any help is greatly appreciated, thanks guys!


11 replies

Userlevel 1
Badge +6

I can’t edit my post, so added some more info. Here are the logs from my production app:
 

default	20:40:24.434202-0400	Runner	[Purchases] - DEBUG: ℹ️ API request completed with status: GET /v1/subscribers/********/offerings 200
default 20:40:24.434345-0400 Runner [Purchases] - DEBUG: ℹ️ Requesting products from the store with identifiers: {(
"burntbase_monthly"

)}
default 20:40:24.598733-0400 Runner [Purchases] - DEBUG: ℹ️ Products request finished.
default 20:40:24.598833-0400 Runner [Purchases] - DEBUG: 💰 Retrieved SKProducts:
default 20:40:24.599008-0400 Runner [Purchases] - WARN: 🍎‼️ Invalid Product Identifiers - (
"burntbase_monthly"
)
default 20:40:24.599173-0400 Runner [Purchases] - DEBUG: ℹ️ 1 completion handlers waiting on products
default 20:40:24.599379-0400 Runner [Purchases] - WARN: 🍎‼️ Could not find SKProduct for (
"burntbase_monthly"
)
There is a problem with your configuration in App Store Connect.
More info here: https://errors.rev.cat/configuring-products
default 20:40:24.606324-0400 Runner [Purchases] - DEBUG: ℹ️ Vending PurchaserInfo from cache.
default 20:40:40.833985-0400 Runner [Purchases] - DEBUG: ℹ️ Vending Offerings from cache
default 20:40:40.836437-0400 Runner [VERBOSE-2:ui_dart_state.cc(199)] Unhandled Exception: type 'Null' is not a subtype of type 'Package' in type cast
#0 RevenueCatService.purchase (package:bbflutter/services/revenue_cat_service.dart:8)
<asynchronous suspension>
default 20:40:42.304882-0400 Runner [Purchases] - DEBUG: ℹ️ Vending Offerings from cache

Here is it working in sandbox (same behavior in testflight):

 

Here is the in-app purchases approved Saturday morning:
 

Agreements signed:
 

 

Userlevel 5
Badge +8

Hey @BurntBase! 👋

If the app has never been released on the App Store, it must be released before in-app purchases will work in production, even if you download with a code. We recommend releasing, then waiting up to 24 hours to ensure purchases work as expected before starting marketing/release campaigns.

After the app has been released, additional products you may add in the future don’t require an app update to work after being approved by Apple (it’s usually just the first, initial release that causes the delay).

Userlevel 1
Badge +6

@cody ahh thank you! Releasing now, I was really confused about this one. I was going off this blog post: https://www.revenuecat.com/blog/the-ultimate-guide-to-subscription-testing-on-ios#production and did not realize I had to release first. I will post an update in this thread in 24-48 hours to confirm.

Userlevel 1
Badge +6

@cody Update, released the app and in-app purchases instantly worked. Thank you guys again for the awesome product and appreciate the support!

@BurntBase and @cody what are the steps to take to “release”.  My app is live in the app store, but the in-app purchases don’t work.  

 

Badge

@Helen Ronnenbergh - Did you find a solution?

 

Does anyone know how to associated the IAP to the version page after the first submission is rejected?

 

Problem

My Subscription IAP is locked in a “Developer Action Needed” state.

 

Why?

The initial App Version, 4.0.2, and associated Subscription was rejected because it did not have a “Restore Purchase” link.

 

What did we do next?

We produced 4.0.3 that includes a Restore Purchase link.

 

Blocker

I can no longer associated the Subscription to the new version because “Developer Action Needed” is blocking the association, we believe.

Changing the Subscription name to reflect a change does not move it out of Developer Action Needed to “Prepare for Submission”

 

Notes

Apple states on the Subscription, “Create your subscription, then select it from the app’s In-App Purchase and Subscriptions section on the version page before submitting the version to App Review.”

However, I cannot select it from the version page because it is “Developer Action Needed”

 

Update

August 28, 17:26 - The app has been approved for over 24 hours and the Subscription link on the popup page does not work in Production.  It does work in Test Flight.

@Chris Wilke no unfortunately not, I wrote to Revenuecat support as well but didn't receive a reply.    I’m still waiting for Apple to get back to me, they approved the App and the inapp purchase but not the subscription.  But I can’t see why not.  I also a status “Developer action required”

Badge

@Helen Ronnenbergh - Here is what I am trying and the history that led to it:

History

  1. Create first Subscription (in-app-purchase) and appropriate metadata for the app
  2. Associate Subscription with new build on Version screen
  3. Submit Version with Subscription
  4. Version rejected due to missing metadata and Privacy Policy on Subscription page

Problem: Deadlock - Can no longer resubmit the Subscription because it is not “selectable” anymore

If this is the first in-app-purchase for the app AND it is rejected on the FIRST submission, it is dead.

 

Impact

My subsequent fix to the app was approved, but since my Subscription was in a “Developer Action Needed” state, it is not connected in Production.  This left me with a Production app and no subscription option.

 

Next Attempt to Fix It:

I created a new Subscription with the same ID but added a “2” to the end.

I updated the app to use the new subscription ID and I resubmitting that bundle tonight.

 

Resources

https://developer.apple.com/forums/thread/13324

I am not sure if this is true, but in the above link, I found this:

“The other problem is that when an in-app purchase is submitted for review, and gets returned to you for "correction", it is impossible to re-submit it back to the store because there is no way to fix the corrections and the newly submitted version won't update to re-send the in-app purchases with the current app version you want to be submitted. This is a technical problem on Apple's side. The only way to fix it is for Apple to go in their and manually fix it.”

 

 

I am not sure Apple can manually “fix it,” so I am just recreating the Subscription and resubmitting.

 

Badge

@Helen Ronnenbergh 

My app is now working in Production.

I had to do these three things:

  1. I had to create a new Subscription Product Id in the App Store
  2. I had to update the Product Id in the Products section in RevenueCat
  3. I had to “Attach” the new product to the Entitlements

I also “Made Current” the Offering that contained the products.

 

Why did this work?

If Apple rejects your IAP the first time it is submitted, it appears to be “dead” and you have to create a new one.

Once that was complete, I had to ensure this Product Id was associated to the App and Entitlement in RevenueCat.

Thanks @Chris Wilke I got it to work by doing what you suggested.  THANK YOU!

Badge +2

fyi...i’ve run into this twice now where apple does approve the app and the subscription after an initial rejection (once because the reviewer simply missed where my terms of service link was).  that rejection ‘sticks’ on the subscription and despite getting a specific email from appstore connect saying the subscription itself is approved...it never works in production no matter how long i wait.  only way to ‘unstick it’ as per above is to blow it away and pray you get through the review the first time clean.  coo-koo...

Reply