Offerings can't be fetched from AppStoreConnect

  • 10 March 2023
  • 0 replies

Badge +2

Hi cool revenuecats and kittens,

We have built an app and we are working with revenuecat to facilitate in-app subscriptions. We’ve set everything up correctly, but for some reason there is still something going wrong in getting the subscriptions for iOS. It works for Android. We have tried to debug and found the following:

When we try to await Purchases.getOfferings(), this is the output that we are getting: 


[Error: There is an issue with your configuration. Check the underlying error for more details. There's a problem with your configuration. None of the products registered in the RevenueCat dashboard could be fetched from App Store Connect (or the StoreKit Configuration file if one is being used). 

More information:] 


If we try to send API calls directly to RevenueCat using postman, we do get offerings back from the API. Just like this code we tried in-app, that seems to work.


 const options = {

   method: "GET",

   headers: {

     accept: "application/json",

     "X-Platform": "ios",

     "Content-Type": "application/json",

     Authorization: ourBearerKey,




 const purchaseOfferings = await fetch(




   .then((response) => response.json())

   .catch((err) => console.error(err))


So it seems like a problem with the Purchases.getOfferings()that doesn’t seem to work for iOS. We have configured everything correctly in the app store as far as we know. The only thing we can think of that might be a problem is that the app is in the “Prepare for Submission “state, but it says online that this shouldn’t be a problem for subscriptions. We went through all the standard solutions offered here:

And we looked through other solutions as well but nothing seems to help us any further.


Does anyone have any idea what could be the problem? 

0 replies

Be the first to reply!