Question

Detection of the "Billing Library" version fails in Play Store

  • 11 November 2021
  • 2 replies
  • 584 views

Badge +4

Getting the following error on Play Console.

 

We've detected this app uses an unsupported version of Play billing. Please upgrade to Billing Library version 3 or newer to publish this app.

 

I am using the latest revenuecat library

 

implementation 'com.revenuecat.purchases:purchases:4.3.1'

 

FYI, we are using Dexguard .

How to fix the error ?

 

 


2 replies

Userlevel 3
Badge +3

Are you by any chance use any dependency that requires `tools:node="replace”` in the AndroidManifest? We have seen people get this warning in Google Play because of that. Link to related GitHub issue → https://github.com/RevenueCat/purchases-flutter/issues/255#issuecomment-937947386

Badge +4

No we dont have  `tools:node="replace”` in our Android manifest. 

Reply