Cordova Plugin Purchases not working at all on IOS

  • 8 January 2022
  • 3 replies


I have installed cordova-plugin-purchases on my app which works fine on the android version.

But on IOS while i am following all the documentation on both physical device and simulator and while my setup seems ok, i cannot trigger any purchases related action/function.

I did all the stuff described here: Testing purchases in App Store Sandbox

The actual behavior seems like all plugin functions are empty of code.

I do not get either a success or an error callback at all from whatever method i ‘ve tried to call.

I have tried in both actual devices and simulator with xcode builds.

If needed i can post sample code.


Best answer by mcmobilapps 16 January 2022, 08:37

View original

3 replies

Userlevel 3
Badge +7

Hey @mcmobilapps ,

Can you send over some debug logs that reproduce this? Be sure to censor any sensitive information. 

You can enable debug logs by following this guide. After they're enabled you'll see logs like this in the console:

[Purchases] - DEBUG: No cached entitlements, fetching
[Purchases] - DEBUG: GET /v1/subscribers/<APP_USER_ID> 200
[Purchases] - DEBUG: Purchaser info updated, sending to delegate

Please ensure the debug logs include the entire app life-cycle, including the messages printed during initialization of the SDK. The more information you include here, the better we'll be able to help.



I found out the solution and that was the swift version on xcode.

It is important to also check the version is set to 5 before every build because for some reason it resets to 4 after running cordova commands.



I have the same issue. My project is already using swift 5 and is targeting iOS 15. It’s something I’m implementing on iOS only, so I don’t have and android project