The receipt isn't valid in the simulator with "StoreKit testing" at RevenueCat

  • 1 May 2022
  • 1 reply

Badge +1


I've the above error message when testing on the simulator and I don't know what the reason for this error is. The API key should be correct. I've taken the Public API Key. 
The configuration looks like this here: 
Purchases.configure(withAPIKey: Config.getConfiguration(for: .revenueCatAPIKey))

I don't know where the problem could be. 
I'm afraid that I've to reset my simulator to cancel the subscription. 
FYI: I don't use the sandbox testing from Apple. I just created the StoreKit configuration in my Xcode project and uploaded it to RevenueCat accordingly. 

For some reason, 0 products are also displayed here. Although when I click on it have deposited products there.


Does anyone have any ideas what this could be? 
If there is more information missing please let me know.

1 reply

Badge +1

I just tried to build on another scheme. there it worked. whats the reason for this?