Question

Problem with xCode building - using version 3.9.2

  • 28 September 2022
  • 1 reply
  • 151 views

Userlevel 2
Badge +6

My problem is this. I have an app that gives me an unknown error (error build: Command PhaseScriptExecution failed with a nonzero exit code) during the build in Xcode. The only plugin I have not updated - my current version is 3.9.2 - is purchase_flutter.
I would like to know if the error could depend on the plugin. 
If it is necessary to upgrade to the latest version.
I ask this because I would like to avoid it for this interim release and implement it in the new version next year

Thanks


This is my configuration.
Translated with DeepL

 

[✓] Flutter (Channel stable, 3.0.5, on macOS 12.6 21G115 darwin-x64, locale it-IT)
    • Flutter version 3.0.5 at /Users/carlosacchetti/Developer/flutter
    • Upstream repository https://github.com/flutter/flutter.git
    • Framework revision f1875d570e (3 months ago), 2022-07-13 11:24:16 -0700
    • Engine revision e85ea0e79c
    • Dart version 2.17.6
    • DevTools version 2.12.2

[✓] Android toolchain - develop for Android devices (Android SDK version 30.0.3)
    • Android SDK at /Users/carlosacchetti/Library/Android/sdk
    • Platform android-31, build-tools 30.0.3
    • Java binary at: /Applications/Android Studio.app/Contents/jre/Contents/Home/bin/java
    • Java version OpenJDK Runtime Environment (build 11.0.10+0-b96-7281165)
    • All Android licenses accepted.

[✓] Xcode - develop for iOS and macOS (Xcode 14.0.1)
    • Xcode at /Applications/Xcode.app/Contents/Developer
    • CocoaPods version 1.11.2

[✓] Chrome - develop for the web
    • Chrome at /Applications/Google Chrome.app/Contents/MacOS/Google Chrome

[✓] Android Studio (version 2020.3)
    • Android Studio at /Applications/Android Studio.app/Contents
    • Flutter plugin can be installed from:
      🔨 https://plugins.jetbrains.com/plugin/9212-flutter
    • Dart plugin can be installed from:
      🔨 https://plugins.jetbrains.com/plugin/6351-dart
    • Java version OpenJDK Runtime Environment (build 11.0.10+0-b96-7281165)

[✓] IntelliJ IDEA Community Edition (version 2021.1.1)
    • IntelliJ at /Applications/IntelliJ IDEA CE.app
    • Flutter plugin can be installed from:
      🔨 https://plugins.jetbrains.com/plugin/9212-flutter
    • Dart plugin can be installed from:
      🔨 https://plugins.jetbrains.com/plugin/6351-dart

[✓] VS Code (version 1.71.2)
    • VS Code at /Applications/Visual Studio Code.app/Contents
    • Flutter extension version 3.48.0

[✓] Connected device (3 available)
    • iPhone CS (mobile) • 00008110-000A5CD42682801E • ios            • iOS 16.0.2 20A380
    • macOS (desktop)    • macos                     • darwin-x64     • macOS 12.6 21G115 darwin-x64
    • Chrome (web)       • chrome                    • web-javascript • Google Chrome 105.0.5195.125
    ! Error: Apple Watch di Carlo needs to connect to determine its availability. Check the connection between the device and its companion
      iPhone, and the connection between the iPhone and Xcode. Both devices may also need to be restarted and unlocked. (code 1)

[✓] HTTP Host Availability
    • All required HTTP hosts are available

• No issues found!


1 reply

Userlevel 2
Badge +6

I would add, but you can also see from the doctor, that the problem occurred after updating to xcode 14.0.1

Reply