Solved

Offerings are empty in developer build on ios but work fine in sandbox on testflight

  • 1 December 2021
  • 4 replies
  • 47 views

Badge +3

I’ve done everything described here 

and it’s working fine in sandbox but when we published application into app store, the app store version didn’t work, in the logs we got this error:

Could not find SKProduct for (
"subscription_30",
"subscription_360",
"subscription_180"
)
There is a problem with your configuration in App Store Connect.
More info here: https://errors.rev.cat/configuring-products

Is there a way to debug or fix it?

icon

Best answer by ryan 8 December 2021, 01:31

View original

4 replies

Userlevel 5
Badge +9

Is this for a live app you just launched? There are propagation times when a new app is released for the first time with in-app purchases and sometimes the app becomes available before the products, everything should get in-sync within 24hrs. 

Badge +3

Yeah it’s for app in the app store, a several days have already passed since releasing it in app store but we still getting the same error

Badge +3

Any updates on it? Is there may be some way to debug it more thoroughly? Or should we provide more info avout this issue? 

Userlevel 5
Badge +9

Things to triple check are:

  1. The product IDs match exactly
  2. The bundle ID in XCode matches exactly with App Store Connect
  3. You have signed the Paid Applications Agreement

I’ve never heard of a scenario where things work for app review but break on production - definitely strange. All of the things we know that could cause that configuration error are outlined in the article you linked, so are all areas to check and debug. 

 

Reply