Solved

Unable to "Disconnect from Google" in project settings

  • 10 December 2021
  • 8 replies
  • 109 views

Badge +5

I’m trying to setup Real Time Developer Notifications, but keep getting a 400 error every time I click the button. Not sure if this is related to the switch from Apps to Projects.

 

icon

Best answer by Joe C. 14 December 2021, 21:32

View original

8 replies

Userlevel 3
Badge +7

Hey @Joe C. ,

I saw this was submitted as Zendesk ticket, but to summarize it looks like you found the solution to disconnect from the existing developer notification by adding the old service account. 

Badge +5

Thanks Jazmine, indeed that was the solution but it wasn’t obvious to figure out. Leaving this as feedback in case someone else encounters the same issue.

The existing service account key is required to disconnect a currently connected project, which is counter intuitive. If for some reason, you lost the key and want to disconnect Google notifications to connect a new one, there is no way to do with the existing functionality.

Badge +1

Same error here. And always got 400 even after creating a new Google Cloud Account. 

Sorry I don't understand the solution you mentioned above @Joe C. 

Could you offer more detailed info of what did you do to solve this? Thx

Badge +5

Same error here. And always got 400 even after creating a new Google Cloud Account. 

Sorry I don't understand the solution you mentioned above @Joe C. 

Could you offer more detailed info of what did you do to solve this? Thx

Hi, in my case, the problem was that the UI expects you to provide the original service credential key even for disconnecting from Google. If you have a connection already established, you need to provide the original service account in the “Service Account Credentials JSON” field.

Badge +1

Same error here. And always got 400 even after creating a new Google Cloud Account. 

Sorry I don't understand the solution you mentioned above @Joe C. 

Could you offer more detailed info of what did you do to solve this? Thx

Hi, in my case, the problem was that the UI expects you to provide the original service credential key even for disconnecting from Google. If you have a connection already established, you need to provide the original service account in the “Service Account Credentials JSON” field.

I see. What I want to do is the opposite of yours, connect the Google, which always fails with the error code 400.

Still very grateful.

Badge +4

I also get “Received status code 400” every time i want to connect…
Any suggestions?

Badge +2

@vulgur @mwerder I’m currently facing the same issue, did you manage to resolve this?

Badge +4

@Maru , yes i messed up something on the google side (setting up Google Cloud Pub/Sub). But I cant remember exactly sorry.

Reply