Solved

Credentials issue on android after 5 days

  • 2 November 2021
  • 11 replies
  • 395 views

Userlevel 1
Badge +3

Hello, I’m getting credentials issue with google play store in my flutter app. I created them about 5 days ago so more than 36h has passed. Also I creted other credentials but couldnt get it to work neither.

 

DEBUG(19728): ℹ️ API request started: POST /receipts

D/[Purchases] - DEBUG(19728): ℹ️ API request completed with status: POST /receipts 503

E/[Purchases] - ERROR(19728): 🤖‼️ There was a credentials issue. Check the underlying error for more details.

I/flutter (19728): ERROR

I/flutter (19728): PlatformException(11, There was a credentials issue. Check the underlying error for more details., {code: 11, message: There was a credentials issue. Check the underlying error for more details., readableErrorCode: InvalidCredentialsError, readable_error_code: InvalidCredentialsError, underlyingErrorMessage: Invalid Play Store credentials., userCancelled: false}, null)

 

 

icon

Best answer by Anton Alberdi 5 November 2021, 10:49

View original

11 replies

Userlevel 1
Badge +3

Is there any other way to contact with support? I really need help with this

Userlevel 4
Badge +8

Hey @Anton Alberdi! Apologies for the delay here.

Can you confirm you’ve followed our Play Store Service Credentials guide? I took a look at logs on our end, and it seems like your credentials are invalid and we aren’t able to validate purchases for your app. You might be missing some of the required permissions from our guide: https://docs.revenuecat.com/docs/creating-play-service-credentials

I’d recommend re-generating these credentials, ensuring you have selected the correct permissions for the correct project and service account.

Userlevel 1
Badge +3

Hello, yes, I have created the credentials 3 times.

 

First time I waited 2 days and didnt work

 

Second time I waited over a week and it didnt work.

 

Third time I’m still waiting for 24h.

 

 

I really don’t know what to do. 

 

Userlevel 1
Badge +3

Finally I managed to fix it! 

when I first created the subscription packages google didnt ask me to fill each countries prices individually I didnt had that option.

After editing the price google asked me to fill all the countries prices and after apllying my subscriptions started working correctly.

Badge +4

Im also trying to resolve the same issue, 

 

I have not set a price as such I have only set a price in a subscription but struggling to get my purchases accepted, 

 

is it possible to see screenshot examples so I can clone them to a degree and at least get something working ?

Badge +4

I fixed my issue forgot this thread was still open.

Badge

I fixed my issue forgot this thread was still open.

Can you tell the solution, how you fixed the issue ?

Badge +4

You have to add a price, even though you have a subscription price, 

Badge

You have to add a price, even though you have a subscription price, 

@appstrader Do you mean that we must set your app to Paid ​​​​​​? 

Badge +4

You have to add a price, even though you have a subscription price, 

@appstrader Do you mean that we must set your app to Paid ​​​​​​? 

Yes subscription does not work unless you have an app price, after that mine worked okay.

Badge +1

Just adding my experience. Anton’s answer above put me on to the solution. I’m using an emulator, logged in to Google Play with my account and got the credentials issue error. Symptoms were that it still said I had the free version but if I tried to subscribe again it said I was already subscribed. 

I had to go to the main release production page in the dashboard and add the countries. Then back to my subscription page and I could see that on the ‘edit price’ page, all the countries were now listed. Afterwards, I could subscribe ok.

I’m just using an internal test track and did not need to make it a paid app.

EDIT: I should say that more than 5 minutes passed while doing all the above, so the test monthly subscription would have expired. Don’t know if that something to do with it succeeding afterwards. Also my subscription had been created less than 24 hours ago.

Reply