CORS issue - "Connect to Google" button in App Settings not working

  • 10 September 2021
  • 4 replies
  • 48 views

Badge

We’ve had various service accounts set up to access our Google Play Store account for some time and have never had issues.  

Though we’ve completed the described steps in your documentation to enable Pub/Sub, the “Connect to Google” button simply presents the “loading state” and then goes back to the “enabled state” after about 15-20 seconds of loading.  

No additional data is presented to us.  

Below is a screenshot of the console from my browser.  Looks like there is a CORS issue on the site.  

 

 


4 replies

Userlevel 3
Badge +7

Hey @Clint Gossett! 👋

I sent this over to the engineering team, and they weren’t able to reproduce this issue. It sounds like a server issue/timeout might have caused this.

Are you able to try this again, and see if you’re still having an issue? Additionally, could you try in a separate browser to see if that has something to do with it?

Badge

Hello, yes, I tried again without success.  I'm in India, is it possible that this may play a factor?  I'm using Chrome, can't imagine another browser would be more compatible with your platform.  I did try Safri...didn't work, but didn't dig into why. 

 

Is there another way to get this enabled? 

 

Being that this is a CORS issue, it is in fact defined as a server configuration issue.  Has your team validated the functionality works in your production environment?  

Badge

@cody , below is a screenshot from Safari which shows the same issue as reported by Chrome.  Though your development team may not be able to recreate the issue, your DevOps team is likely the owner of CORS policies across your production environments.  Perhaps involving them is the right next step?  

 

Badge

@cody on a hunch I went ahead and updated our Google Playstore Auth JSON.  Once updated, the “Connect to Google” action WAS successful.  

Not sure why the console errors were indicating CORS errors, but we are unblocked.  

Thank you!

Reply