Question

Problem installing Revenuecat with swift Packager manager

  • 8 April 2022
  • 3 replies
  • 38 views

Badge +2

Im having some problems installing the revenuecat package using swift package manager. This happens when I try and clone a project from scratch and install the required packages. The error reads

“Dependencies could not be resolved because no versions of “purchases-ios” match the requirement 5.5.0 and root depends on “purchases-ios” 5.5.0.”

If anyone could has experienced this problem before and knows of ways to solve it that would be very helpful. 

Thanks! Michael

 


3 replies

Userlevel 4
Badge +8

Hi! 

It seems like Swift Package Manager is trying to install version 5.5.0, but the latest one available for purchases-ios is 4.1.0.

 

To get the latest available version automatically, make sure that you set the dependency rules to “Up to next major” and set the version to 4.1.0. 

 

Hope this helps! 

Badge

Ok , i spend a day trying to install this tool

 

COCOAPODS crashes, swift package manager does not seem to work either. Is there a way to install this tool - are the installation instructions maintained to be current with all of the various updates? 

Userlevel 4
Badge +8

@brian mcdonald could you elaborate on the issues you’re getting? 

What’s happening when you try to install with cocoapods? For Swift Package Manager, are you getting an error? 

Installation instructions in https://www.revenuecat.com/docs/ios should be up to date

Reply