Question

Expo | using storekit-configuration json, but getting error about it being unable to fetch from the app store

  • 31 March 2024
  • 1 reply
  • 90 views

Badge

Sorry for the long title!

 

Basically, I am trying to just do the basic storekit-configuration json in my react native and expo project. I have the storekit-configuration.json that I copied and pasted from an Xcode project, but I am getting the following error:

 

[Error: There is an issue with your configuration. Check the underlying error for more details. There's a problem with your configuration. None of the products registered in the RevenueCat dashboard could be fetched from App Store Connect (or the StoreKit Configuration file if one is being used). 

 

To be fair, I have been getting this error even before I tried to use the configuration file, but I thought this would help. I’ve seen some similar issues and followed what they said, but it still will not work. 

 

Has anyone had luck with this?


This post has been closed for comments

1 reply

Userlevel 5
Badge +9

Hey @ashercn97,

You might be running into an issue where only apps that are built and run directly by Xcode can use StoreKit configuration files: https://www.revenuecat.com/docs/test-and-launch/sandbox/apple-app-store#:~:text=storekit%20testing%20requires%20running%20app%20from%20xcode