Question

CocoaPods could not find compatible versions for pod "PurchasesHybridCommon"

  • 16 February 2023
  • 4 replies
  • 1862 views

Badge +1

I am facing problems in the latest version of iOS.

Xcode version: Version 14.2 (14C18)
POD Target: 11.0

 

[!] CocoaPods could not find compatible versions for pod "PurchasesHybridCommon":
  In Podfile:
    purchases_flutter (from `.symlinks/plugins/purchases_flutter/ios`) was resolved to 4.10.0, which depends on
      PurchasesHybridCommon (= 4.13.1)

None of your spec sources contain a spec satisfying the dependency: `PurchasesHybridCommon (= 4.13.1)`.

You have either:
 * out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`.
 * mistyped the name or version.
 * not added the source repo that hosts the Podspec to your Podfile.

 

flutter doctor
Doctor summary (to see all details, run flutter doctor -v):
[✓] Flutter (Channel stable, 3.7.0, on macOS 13.1 22C65 darwin-arm64, locale tr-TR)
[✓] Android toolchain - develop for Android devices (Android SDK version 30.0.3)
[✓] Xcode - develop for iOS and macOS (Xcode 14.2)
[✓] Chrome - develop for the web
[✓] Android Studio (version 2021.1)
[✓] VS Code (version 1.75.1)
[✓] Connected device (3 available)
[✓] HTTP Host Availability

• No issues found!


4 replies

Badge +5

Try 
Flutter Clean
Pub Get

Pod update

Userlevel 5
Badge +8

Hey @BigLayer, in addition to the suggestion above, were you able to run `pod repo update`?

Had the same issue here. I ran both the suggestions and it worked.
Thanks, guys!

Badge +2

With an M1 or M2 chip the “pod update” command is:

arch -x86_64 pod update

Reply