Question

Cannot Build for IOS

  • 16 April 2024
  • 3 replies
  • 93 views

Badge +3

I have added the latest RevenueCat dependency (purchases_flutter: ^6.26.0)  in my Flutter project. However, when I try to run my IOS project I am getting the following errors. 

 

Failed to build iOS app

Error (Xcode): double-quoted include "LaunchReviewPlugin.h" in framework header, expected angle-bracketed instead

/Volumes/Data/Projects/demo/ios/Pods/Target%20Support%20Files/launch_review/launch_review-umbrella.h:12:8

 

Error (Xcode): 'Flutter/Flutter.h' file not found

/Users/abc/.pub-cache/hosted/pub.dev/launch_review-3.0.1/ios/Classes/LaunchReviewPlugin.h:0:8

 

Error (Xcode): (fatal) could not build module 'launch_review'

/Users/abc/Library/Developer/Xcode/DerivedData/Runner-ffencdqrnvwqyfcxfawlmzddeskh/Build/Intermediates.noindex/Pods.build/Debug-iphonesimulator/launch_review.build/VerifyModule/launch_review_objective-c_arm64-apple-ios12.0-simulator_gnu11/Test/Test.framework/Headers/Test.h:0:8

 

Error (Xcode): (fatal) could not build module 'Test'

/Users/abc/Library/Developer/Xcode/DerivedData/Runner-ffencdqrnvwqyfcxfawlmzddeskh/Build/Intermediates.noindex/Pods.build/Debug-iphonesimulator/launch_review.build/VerifyModule/launch_review_objective-c_arm64-apple-ios12.0-simulator_gnu11/Test/Test.m:0:8

 

Error (Xcode): (fatal) could not build module 'launch_review'

/Users/abc/Library/Developer/Xcode/DerivedData/Runner-ffencdqrnvwqyfcxfawlmzddeskh/Build/Intermediates.noindex/Pods.build/Debug-iphonesimulator/launch_review.build/VerifyModule/launch_review_objective-c_x86_64-apple-ios12.0-simulator_gnu11/Test/Test.framework/Headers/Test.h:0:8

 

Error (Xcode): (fatal) could not build module 'Test'

/Users/abc/Library/Developer/Xcode/DerivedData/Runner-ffencdqrnvwqyfcxfawlmzddeskh/Build/Intermediates.noindex/Pods.build/Debug-iphonesimulator/launch_review.build/VerifyModule/launch_review_objective-c_x86_64-apple-ios12.0-simulator_gnu11/Test/Test.m:0:8

 

Could not build the application for the simulator.

Error launching application on iPhone 15 Pro Max.


This post has been closed for comments

3 replies

Badge +3

After upgrading Flutter to the latest version, I am gettin getting the following error now.

 

Error (Xcode): Undefined symbol: nominal type descriptor for RevenueCat.PresentedOfferingContext

 

Error (Xcode): Undefined symbol: RevenueCat.Package.__allocating_init(identifier: Swift.String, packageType: RevenueCat.PackageType, storeProduct: RevenueCat.StoreProduct, presentedOfferingContext: RevenueCat.PresentedOfferingContext) -> RevenueCat.Package

 

Error (Xcode): Undefined symbol: direct field offset for RevenueCat.Package.presentedOfferingContext : RevenueCat.PresentedOfferingContext

 

Error (Xcode): Undefined symbol: RevenueCat.Offering.metadata.getter : [Swift.String : Any]

 

Error (Xcode): Undefined symbol: RevenueCat.Offerings.currentOffering(forPlacement: Swift.String) -> RevenueCat.Offering?

 

Error (Xcode): Linker command failed with exit code 1 (use -v to see invocation)

 

Could not build the application for the simulator.

Error launching application on iPhone 15 Pro Max.

Userlevel 4
Badge +8

Hi, can you try completely reinstalling? Sometimes doing this will fix these errors.

Badge +3

What you want me to reinstall?