Question

Can't upgrade Cordova plugin

  • 23 November 2022
  • 0 replies
  • 10 views

Badge +3

Hi there!

I’m trying to update cordova-plugin-purchases to a version that uses Google Billing Library version 4, as I can no longer submit to Google Play with my current version.

I removed 2.1.1 that I was using and tried to install 2.4.2 with the following result:

src-cordova % cordova plugin add cordova-plugin-purchases@2.4.2
Installing "cordova-plugin-purchases" for android
Installing "cordova-annotated-plugin-android" for android
Subproject Path: CordovaLib
Subproject Path: app
Subproject Path: CordovaLib
Subproject Path: app
Installing "cordova-plugin-purchases" for ios
Plugin dependency "cordova-annotated-plugin-android@1.0.4" already fetched, using that version.
Dependent plugin "cordova-annotated-plugin-android" already installed on ios.
Running command: pod install --verbose
Failed to install 'cordova-plugin-purchases': Error: pod: Command failed with exit code 31
at ChildProcess.whenDone (/Users/XXXXXX/quasar/tptk2/src-cordova/node_modules/cordova-common/src/superspawn.js:136:25)
at ChildProcess.emit (node:events:513:28)
at maybeClose (node:internal/child_process:1091:16)
at Socket.<anonymous> (node:internal/child_process:449:11)
at Socket.emit (node:events:513:28)
at Pipe.<anonymous> (node:net:313:12)
pod: Command failed with exit code 31

I have also tried other version all the way up to the latest and the only version that will install is the 2.1.1 that I already had.

Any help or suggestions would be hugely appreciated!

Simon


0 replies

Be the first to reply!

Reply