Bank vaiidation step prevents purchase to complete

  • 1 June 2023
  • 2 replies

Badge +3

Some banks put an extra step in the purchase flow to verify the transaction with a banking app. We have had a report that our app doesn’t seem to work when unlocking content via an in-app purchase when this verification step happens. We use RevenueCat Purchases SDK v3 at the moment on iOS.

The same issue was reported in this thread but there’s no public answer.

This has been reported by a customer and I don’t know how to test or reproduce this.

From the customer:

I’ve been onto Apple twice and even purchased an iTunes voucher and it has still not resolved the issue. Apple have advised that it is a problem with the app and not Apple which I can agree with. All the payment information is fine, there is a credit on the account but when we go to purchase the app it takes us to the screen asking us to approve the purchase in the mobile banking app. The request is approved in the banking app but when we go back to the app screen it simply will not let us click on the button saying ‘I have approved the request’. We have tried this process numerous times now and even with Apple on the phone and sharing our screen. All the information is fine from our end and they have said advised it is the app designer which we need to speak to. 

Any help appreciated

2 replies

Userlevel 4
Badge +6

Hey there,


Can you create a support ticket with us so we can look more into this. This will likely require more information that what would be shared in a community post! 


You can open a support ticket by clicking here:

Badge +3

Thanks. I opened a ticket earlier today and linked to this post. See you on the ticket