Question

Firebase Extension, cant update

  • 2 October 2022
  • 1 reply
  • 8 views

Badge +4

Hi!
Im having problem updating the firebase extension and are stuck on 0.1.4.

I get a 400 http error when pressing update, with response:

{
"error": {
"code": 400,
"message": "Request had 1 validation errors: `allowedEvents.com.revenuecat.v1.non_renewing_puchase`: allowed event type 'com.revenuecat.v1.non_renewing_puchase' is not listed in the extension spec.",
"status": "INVALID_ARGUMENT",
"details": [
{
"@type": "type.googleapis.com/google.rpc.BadRequest",
"fieldViolations": [
{
"field": "allowedEvents.com.revenuecat.v1.non_renewing_puchase",
"description": "allowed event type 'com.revenuecat.v1.non_renewing_puchase' is not listed in the extension spec"
}
]
}
]
}
}

 


1 reply

Badge +4

Unchecked and checked all selection boxes for events and it worked, but let the post stay for the developers to look into.

Reply