Able to fetch products locally, but not when distributed through Google Play

  • 20 October 2022
  • 3 replies

Badge +3


When publishing my Android app to the Internal Testing or Closed Testing track through Google Play Console, no products are being fetched and shown. However, it works when running the app locally from Android Studio and launching it on a physical phone. In this scenario, both fetching products and making purchases (that shows up in RevenueCat sandbox environment) works as expected.

What I’ve verified so far:

  • Made sure that the product identifiers in RevenueCat matches the Subscription Product ID (but not Base Plan ID) in Google Play Console.
  • Made sure that the Base Plans and Offers are active and backwards compatible (I can not activate the Subscription from what I can see).
  • Made sure that the package name matches what's in Google Play Console.
  • Uploaded a signed App Bundle to a closed track, which has been reviewed and published.
  • I have added my gmail address as a tester for the closed track.
  • I have added my gmail address as a license tester with License response: RESPOND_NORMALLY
  • Tested on a physical device
    • When building locally from Android Studio directly to phone - fetching products and making sandbox purchases works
    • When using the app from the closed testing track  - fetching products doesn’t work

What now?

Given that it works when building locally, but not when published through Google Play Console, my guess is that the issue is somwhere in the configurations in Google Play Console. However, since I have already verified everything from this guide, I don’t know what else to do.

It would be helpful to know if I get any errors or simply an empty products list. Does anyone know if there’s a way to see debug logs from an APK published through closed testing? 


  • Framework: Ionic and React
  • Packages:
    • cordova-plugin-purchases: 2.4.0
      cordova-annotated-plugin-android: 1.0.4
      @awesome-cordova-plugins/purchases: 5.45.0
      @capacitor/android: 4.3.0
      @capacitor/app: 4.0.1
      @capacitor/assets: 1.0.0
      @capacitor/core: 4.3.0

  • Device: Android Pixel 3, Android version 12

  • Android Studio Dolphin | 2021.3.1

  • macOS Monterey

Thanks in advance,


Best answer by sanlil 9 November 2022, 16:10

View original

3 replies

Badge +3


When I catch and show the error from Purchases.getOfferings() in an alert box, I get “Invalid action”, which does not seem to be any of the predefined errors from RevenueCat.

Anyone recognizing this error and knows what it means?

Badge +3

When Googling for the error “Invalid action” I get some Cordova related answers, so now I’m starting to suspect that the issue is with the Cordova plugin cordova-plugin-purchases. Would it be possible for someone working on this plugin help me out?

For iOS, everything worked without any issues, but for Android I got a warning telling me that cordova-plugin-purchases is missing dependencies: cordova-annotated-plugin-android, which I found strange since cordova-annotated-plugin-android is a package made for developers of cordova plugins. However, when I remove this package I can’t build the project without getting the compile error package does not exist, so I added it. Could this be related to my problem?

Thanks in advance

Badge +3

The problem was solved by upgrading cordova-plugin-purchases to version 3.2.0 and @awesome-cordova-plugins/purchases to version 6.1.0