Solved

Custom customer list is empty?

  • 6 September 2021
  • 4 replies
  • 39 views

Badge +2

Hi, I have some users with email addresses and also some with keywords.

When I create a custom customer list with the logic ‘Email is not null’ or ‘Keyword is not null’ the filter does not pick up all instances of keywords and returns nil for emails. 

Any tips or workarounds for this?

Thanks so much

icon

Best answer by tina 9 September 2021, 18:12

View original

4 replies

Userlevel 4
Badge +9

Hi @Nic Deane!

When sending subscriber attributes to RevenueCat, are you using the reserved attribute keys? It sounds like you’re using your own attribute for the email attribute. The ‘Keyword’ filter would be the reserved $keyword subscriber attribute for the customer, which comes from your campaign data. 

Badge +2

Hi @tina!

Thanks for the response :)

I haven’t been sending attributes, I just enter in values like email or name via the RC customer lists dashboard. It’s not something I need to do often so doing it manually is ok for now.

I get customer id’s via the in app email function to identify the user, then in the RC dashboard add a keyword so I can keep track of them. 

For a few days here and there the filtered list didn’t pick up all customers that have a keyword. But it seems to be working perfectly now :)

Ps: Thanks so much for the Tee-Shirt I love it! RC is an amazing product!

Userlevel 4
Badge +9

Hey @Nic Deane!

This also could be due to the cache on customer lists since customer lists are refreshed every hour. When you do need to automate the process a bit, the reserved attributes can be written directly by setting the key through .setAttributes(...) (be sure to set the $ prefix) or through special help methods (e.g: .setEmail(...)

Happy to hear you’re enjoying the product so far!

Badge +2

Thanks so much @tina ! 

You’ve been so helpful! I will definitely automate it a bit more when my app grows more. You guys literally saved me 2+ weeks of pain with iOS storekit :smile:

Reply