Solved

Could not validate inappproducts and monetization API permissions

  • 2 January 2024
  • 5 replies
  • 139 views

Badge +1

Permissions to call subscriptions API is checked as validated, but not the other two.

I have gone over the configuration for the service account several times, following your documentation instructions, but never the less I’m stuck. I have also waited several days before refreshing the status again, but it’s the same. I simply don’t know what else to do know except reaching out to you.

I’m creating an app for Android with package name biz.codepower.echonotes and RevenueCat App ID app4742cd71c6.

icon

Best answer by ali-dahud 25 January 2024, 10:06

View original

5 replies

Userlevel 5
Badge +8

 Hey @claus-lysholm-a1b7f0!

Can you try making a test purchase? Sometimes the validator can get hung up if there hasn’t been a test purchase attempted.

You can read more about testing here: https://www.revenuecat.com/docs/google-play-store

Badge +1

When I try to subscribe through the app, there’s no offerings available from the RevenueCat call (const offerings = await Purchases.getOfferings()). Could that not be because the RevenueCat for the Android version setup can not be completed, exactly because of the problem described in my original post?!

Badge

hello @claus-lysholm-a1b7f0 ,
Did you succeed in making it work? I had the same issue but after enabling the  Google Play Android Developer API, it works now. I followed this documentation: https://www.revenuecat.com/docs/creating-play-service-credentials

Badge +1

hello @claus-lysholm-a1b7f0 ,
Did you succeed in making it work? I had the same issue but after enabling the  Google Play Android Developer API, it works now. I followed this documentation: https://www.revenuecat.com/docs/creating-play-service-credentials

I thought the google play android dev API and the Google Play Developer Reporting API were the same.

Badge +1

Boom, that did it! Thought I did, but I did not have Google Play Android Developer API enabled.

Thank you so much!

Reply