Question

Error « trying to validate the receipt »

  • 6 April 2024
  • 2 replies
  • 42 views

Badge +1

While I’ve previously (as of February?) been able to make sandbox purchases in my iOS app, they are now all failing. I initially get a “purchase was successful” message but then get:

 

There was a problem with the App Store. Problem communicating with the Store when trying to validate the receipt.

 

After the initial purchase attempt, these receipts get cached on the device and the verification is re-attempted on each start-up, with the same error. In addition, I’ll then see:

 

Error computing offline CustomerInfo. Will return original error.
Creation error: Unable to compute offline CustomerInfo when purchasing consumable products.

 

I am testing on multiple devices (iOS 16 & 17). I am using Xcode 15.3. I’ve updated to the latest purchases-ios package (4.40.0 -- was previously 4.34.0). I’ve created new sandbox accounts. (This is the only way to get rid of the “cached receipts” above.) I’ve tried with the device logged into my Apple ID and App Store logged into sandbox (this is how it worked a couple months ago) and with both the Apple ID and App Store logged into sandbox account.

Everything is working (login, getCustomerInfo, getOfferings) but the final purchase package call.

Help!


This post has been closed for comments

2 replies

Badge +1

This looks similar to an issue posted 9 days ago:

 

It’s now closed for comments?

Userlevel 4
Badge +8

Hi,

Could you submit a support ticket with debug logs that reproduce this? Happy to take a look.