Question

QuickStart guide step 8: got error "RevenueCat.OfferingsManager.Error error 1"

  • 29 June 2022
  • 7 replies
  • 274 views

Badge

I’m trying to set up RevenueCat, following the QuickStart guide.

My IAP on App Store Connect has the status “Ready to Submit”.

 

I’ve reached step 8: https://docs.revenuecat.com/docs/getting-started#8-displaying-available-products

 

But I get the following error. I’ve searched for the error (RevenueCat.OfferingsManager.Error error 1.) but can’t find any info. I’m unsure as to what to do next.

 

2022-06-29 11:59:12.291881+0100 [AppName][85775:6775520] [Purchases] - DEBUG: ℹ️ No cached Offerings, fetching from network
2022-06-29 11:59:12.292502+0100 [AppName][85775:6775645] [Purchases] - DEBUG: ℹ️ GetOfferingsOperation: Started
2022-06-29 11:59:12.292787+0100 [AppName][85775:6775645] [Purchases] - DEBUG: ℹ️ There are no requests currently running, starting request GET subscribers/$RCAnonymousID%3A2ca8a9a49a8748b190059cf3dc1297fd/offerings
2022-06-29 11:59:12.295060+0100 [AppName][85775:6775645] [Purchases] - DEBUG: ℹ️ API request started: GET /v1/subscribers/$RCAnonymousID:2ca8a9a49a8748b190059cf3dc1297fd/offerings
2022-06-29 11:59:12.522689+0100 [AppName][85775:6775688] [Purchases] - DEBUG: ℹ️ API request completed: GET /v1/subscribers/$RCAnonymousID:2ca8a9a49a8748b190059cf3dc1297fd/offerings 304
2022-06-29 11:59:12.523481+0100 [AppName][85775:6775688] [Purchases] - DEBUG: ℹ️ GetOfferingsOperation: Finished
2022-06-29 11:59:12.523527+0100 [AppName][85775:6775646] [Purchases] - DEBUG: ℹ️ No existing requests and products not cached, starting SKProducts request for: ["premium"]
2022-06-29 11:59:12.523734+0100 [AppName][85775:6775688] [Purchases] - DEBUG: ℹ️ Serial request done: GET subscribers/$RCAnonymousID%3A2ca8a9a49a8748b190059cf3dc1297fd/offerings, 0 requests left in the queue
2022-06-29 11:59:12.542092+0100 [AppName][85775:6775645] [Purchases] - DEBUG: 😻 SKProductsRequest request received response
2022-06-29 11:59:12.542098+0100 [AppName][85775:6775646] [Purchases] - DEBUG: 😻 SKProductsRequest did finish
2022-06-29 11:59:12.542411+0100 [AppName][85775:6775645] [Purchases] - ERROR: 🍎‼️ Error fetching offerings - The operation couldn’t be completed. (RevenueCat.OfferingsManager.Error error 1.)
2022-06-29 11:59:12.542584+0100 [AppName][85775:6775520] [Purchases] - ERROR: 😿‼️ There is an issue with your configuration. Check the underlying error for more details.

 


7 replies

Userlevel 5
Badge +9

Hey @josephm! I see this ticket has been assigned over to an engineer through our support team and they’ll be in touch there!

Seems like some unexpected response is coming back from the SKProductsRequest. Quick debugging step could be to make sure you’re testing on a physical device (not a simulator) and you can try creating a fresh sandbox account in App Store Connect and logging in as that (make sure you confirm the email for the sandbox account before testing too).

Badge

Hey @josephm! I see this ticket has been assigned over to an engineer through our support team and they’ll be in touch there!

Seems like some unexpected response is coming back from the SKProductsRequest. Quick debugging step could be to make sure you’re testing on a physical device (not a simulator) and you can try creating a fresh sandbox account in App Store Connect and logging in as that (make sure you confirm the email for the sandbox account before testing too).

Thanks @ryan. I’ve been testing on a physical device, and I deleted my entire app in App Store Connect and started again today, but still have the same issue 😔

Userlevel 5
Badge +9

Hey @josephm,

Can you confirm you’re signed in correctly with a sandbox tester and you’ve confirmed their email? You may want to try a new sandbox tester.

This error kind of reminds me of this post where Apple was returning malformed data.

 

Badge

Hey @josephm,

Can you confirm you’re signed in correctly with a sandbox tester and you’ve confirmed their email? You may want to try a new sandbox tester.

This error kind of reminds me of this post where Apple was returning malformed data.

 

@ryan , yep, I’m correctly signed in with a new sandbox tester account, after confirming the email. I’ve just tried it again with a new account, and get the same error. Testing on my physical iPad.

Badge

Any resolution to this?  I am experiencing this issue now.

Badge

Any resolution to this?  I am experiencing this issue now.

Turns out my offerings were not configured correctly.

Badge

I have same problem, how to fix it?

Reply