Solved

Cannot "Attach" a Product to an Offering

  • 16 August 2021
  • 4 replies
  • 51 views

Userlevel 1
Badge +4

I am configuring Offerings in RC to be sold via IAP.  Using app logic I will display one of these Offerings to sell to the user. To set this up I have configured three Offering ID’s: “Lifetime” “50_off” “Annual_Subscription”.  Next I set up three products in App Store (iOS) and 3 products in Play Store (Google). In the RC Dashboard when I Attach the 50_off Product to the 50_off Offering it works for Google but fails to attach the App store product.  After attaching the App Store product I can refresh the Offerings page and see that I now have 2 Products attached to the 50_off Offering but clicking the 2-Product link shows me that only the Google product is attached, not the Apple product that I just tried to attach.  

Is the UI broken? Can you help me debug?  This seems to be working differently than maybe a month ago!

icon

Best answer by sundeep 16 August 2021, 23:04

View original

4 replies

Userlevel 5
Badge +9

I just went through the flow and was able to attach an App Store Product - there were some recent frontend changes though so taking a closer look! It’s possible we broke something.

 

Userlevel 1
Badge +4

the broken attach was for the 2nd product.  IE Google product attach was successful but 2nd attach-iOS failed.  And looking at other offerings that we know have multiple attachments are not showing in the UI.

Userlevel 2
Badge +6

Hi @Loredo Sola, sorry for the trouble with this. It turned out to be a bug on our end, but it should be fixed now! Can you try again and let us know if you still experience this issue?

Userlevel 1
Badge +4

Thanks Sundeep & Ryan,

You cats are cool.  It’s now working in RC. Mark this solved.

-----------

FYI Now app store is down!?!?!?  

Reply