Solved

Sometimes events are not sent to Adjust

  • 12 January 2022
  • 2 replies
  • 32 views

Badge +6

Hello,

I seems that sometimes RC doesn’t seem to send the data for events to Adjust, even if the AdjustId is set.

We discovered some discrepancies between our analytics and some of our users don’t have the AdjustId set (might be on our side), but then we have this case where it is set and still RC didn’t send it.

Could somebody from the team help and  have a deeper look at it? Thank you.

 

 

 

 

icon

Best answer by tina 15 January 2022, 01:35

View original

2 replies

Userlevel 5
Badge +10

Hey @Dan Tamas 

It sounds like the app user ID did not have an adjustId attached as a subscriber attribute by the time the event occurred. It looks like your app has webhooks configured. To debug this:

  1. Find a specific RevenueCat customer profile that did not have an Adjust event dispatched
  2. Expand the webhook payload in Event Details 
  3. Look for the subscriber_attributes field in the webhook payload. Does the adjustId appear there? 

If you do see an adjustId in the webhook payload, but no Adjust event dispatched, do let me know and I can open a support ticket on your behalf to gather some more information and example app user IDs. 

Badge +6

Hi @tina 

Indeed it seems that the webhook doesn’t have the adjustId in place.

Is there any way to force RevenueCat to send the events once it gets the AdjustId? We initialise the Adjust SDK later in the app ( we request ATT only after the onboarding).

Thank you :)

 

 

 

Reply