Question

Credentials for Pub/Sub not working

  • 17 February 2023
  • 8 replies
  • 876 views

Badge +2

Hello,

Despite deleting everything and trying it twice from scratch following this doc, we keep getting this error:

Your Google service account credentials do not have permission to create a Google Cloud Pub/Sub topic. 

We have done everything by the books, I have no idea, why this doesn’t work.

 

Any ideas, please?

Thanks,


8 replies

Badge

When you were creating the service account, the first screenshot mislead you. You should have added pub/sub admin. You have to re-create your service account.

Badge

Not working.

I did everything 5 times. Still gives that error

Google Topic IDs: Your Google service account credentials do not have permissions to access the Google Cloud Pub/Sub API. Refer to this guide for more information.

 

Somebody can write here step by step what we gonna do? 

 

Thank you

Badge

When you were creating the service account, the first screenshot mislead you. You should have added pub/sub admin. You have to re-create your service account.

 i did everyting in document. Is there anything not exist in doc what should we do?

Badge +5

Same here, also waited over 36 hours as it said in the warning in docs. Still getting that ‘not have permission to create’ error.

Badge +5

Sorry, figured out that I set role “Cloud Pub/Sub Service Agent”. Setting “Pub/Sub Admin” fixed the issue.

Userlevel 3
Badge +7

Hey Houman,

I know you mentioned you did it all by the book, but did you set the role correctly for the service account, and wait the 36 hours?

If you are you still facing this issue. If so, you may want to reach out to support: https://app.revenuecat.com/settings/support

Badge +2

Yes, I did everything by the book. The problem is not the 36 hours, I waited for 4 days.

The problem is your documentation that is inaccurate. (Sorry)

  1. As the documentation says pick the role for Cloud Pub/Sub Service Agent.
  2. Finish everything as the documentation says until the end. The last sentence in the 400 error paragraph says: “ensure you've enabled Pub/Sub for your project in our guide here.”
  3. Click on that to enable your Pub/Sub capability for your account. 
  4. From here the documentation lacks the next step. Now you need to go back to the roles and change “Cloud Pub/Sub Service Agent” to “Pub/Sub Admin”. This option simply doesn’t exist at first in the drop down, because your Pub/Sub API is not yet enabled. 
  5. Only then you can go back to RevenueCat and press the connect button. Now it will be green.

 

hello Houman,

Can you solve that ?

Reply