Question

Sometimes my customers get an unknown backend error

  • 5 May 2024
  • 1 reply
  • 32 views

Badge +1

Sometimes my customers get the following error while attempting to make a purchase: “There was an unknown backend error. The API key is not intended for the Platform.” with the error code 7810. I can’t find any solutions online so I decided to ask how I should handle this here.


This post has been closed for comments

1 reply

Userlevel 5
Badge +9

Hi @patrikwo,

This is due to a new check on our end where we make sure the API key matches the platform reported by the SDK. This might mean that your Flutter code is not detecting the platform correctly and is using the wrong API key. I recommend double checking your platform detection code and making sure it works on all platforms, including tablets, iPads, Mac, etc.