Question

Service Account Credentials JSON Error

  • 15 November 2023
  • 4 replies
  • 74 views

Badge

Hey i get an error when i paste in the json file in te android app config.

  1. Could not validate subscriptions API permissions

  2. Could not validate inappproducts API permissions

  3. Could not validate monetization API permissions

 

any ideas where i can read how to troubleshoot? they dont have anything on theyr website (or i cant find it)


4 replies

Userlevel 4
Badge +6

Hey @wired !

 

We have a useful document which goes over how to troubleshoot these issues which can be found here: https://www.revenuecat.com/docs/creating-play-service-credentials#troubleshooting-the-credential-validation

 

This is related to permission issues setup in the Google Play Developer account where the JSON is linked to. Once these credentials pass and the permissions are granted, we will be able to verify and the issues should disappear. 

 

Let me know if that helps! 

Badge

Hey @wired !

 

We have a useful document which goes over how to troubleshoot these issues which can be found here: https://www.revenuecat.com/docs/creating-play-service-credentials#troubleshooting-the-credential-validation

 

This is related to permission issues setup in the Google Play Developer account where the JSON is linked to. Once these credentials pass and the permissions are granted, we will be able to verify and the issues should disappear. 

 

Let me know if that helps! 

Hey i followed the complete step(also created a absoluter new google cloud account for that bitte i every time get the same error

Badge

Hey @wired !

 

We have a useful document which goes over how to troubleshoot these issues which can be found here: https://www.revenuecat.com/docs/creating-play-service-credentials#troubleshooting-the-credential-validation

 

This is related to permission issues setup in the Google Play Developer account where the JSON is linked to. Once these credentials pass and the permissions are granted, we will be able to verify and the issues should disappear. 

 

Let me know if that helps! 

PS: i also send a test notification from google cloud (there i have no problems). I also checked the json file. The informations in there are all correct 

Userlevel 4
Badge +6

Hey @wired !

 

Could you please create a support ticket for this so we can look more into your account and see what could be missing here or causing this issue? 

Reply