Question

iOS 17 Simulator Issue

  • 12 July 2023
  • 2 replies
  • 951 views

Badge +5

Hi there,

 

I recently moved to iOS 17 simulator using Xcode 15 beta 4 & Mac Sonoma.

Everything was perfectly working until today but now, I can’t launch my expo app anymore.

The build seems to work without any noticeable issue.

 

Here is the issue I get :

[StoreKit] <SKPaymentQueue: 0x600000010a20>: No observers found that respond to "paymentQueue:shouldAddStorePayment:forProduct:", will not check for purchase intents

 

I’m using "react-native-purchases": "6.3.0" version. Here is my package.json file, hopefully it helps.

 

"dependencies": {
"@babel/runtime": "^7.22.6",
"@expo/react-native-action-sheet": "^4.0.1",
"@react-native-async-storage/async-storage": "1.19.0",
"metro-react-native-babel-preset": "0.77.0",
"@react-native-firebase/analytics": "^18.1.0",
"@react-native-firebase/app": "^18.1.0",
"@react-native-firebase/crashlytics": "^18.1.0",
"@react-native-firebase/firestore": "^18.1.0",
"@react-native-firebase/perf": "^18.1.0",
"@react-navigation/bottom-tabs": "^6.5.8",
"@react-navigation/elements": "^1.3.18",
"@react-navigation/material-top-tabs": "^6.6.3",
"@react-navigation/native": "^6.1.7",
"@react-navigation/stack": "^6.3.17",
"@rneui/base": "^4.0.0-rc.7",
"@rneui/themed": "^4.0.0-rc.7",
"axios": "^1.4.0",
"bcrypt": "^5.1.0",
"expo": "~49.0.2",
"expo-build-properties": "^0.8.3",
"expo-dev-client": "~2.4.5",
"expo-device": "~5.4.0",
"expo-file-system": "~15.4.2",
"expo-linking": "~5.0.2",
"expo-modules-core": "~1.5.6",
"expo-notifications": "~0.20.1",
"expo-splash-screen": "~0.20.4",
"expo-status-bar": "~1.6.0",
"expo-system-ui": "~2.4.0",
"expo-updates": "~0.18.9",
"link": "^1.5.1",
"lodash": "^4.17.21",
"react": "^18.2.0",
"react-content-loader": "^6.2.1",
"react-dom": "^18.2.0",
"react-hot-toast": "^2.4.1",
"react-native": "0.72.3",
"react-native-animated-pagination-dots": "^0.1.73",
"react-native-dialog": "^9.3.0",
"react-native-dropdown-picker": "^5.4.6",
"react-native-gesture-handler": "~2.12.0",
"react-native-iap": "^12.10.5",
"react-native-keyboard-aware-scroll-view": "^0.9.5",
"react-native-linear-gradient": "^2.7.3",
"react-native-pager-view": "6.2.0",
"react-native-purchases": "6.3.0",
"react-native-reanimated": "~3.3.0",
"react-native-safe-area-context": "4.7.1",
"react-native-screens": "~3.22.1",
"react-native-svg": "13.10.0",
"react-native-tab-view": "^3.5.2",
"react-native-timeline-flatlist": "^0.8.0",
"validator": "^13.9.0"
},


   

Do you have any idea about what’s going on?

 

Thanks!

Alex

 


2 replies

Badge +5

Updated Expo this morning + Expo update and issue has gone away. Not sure why it’s ok now but let’s enjoy this 🙃

Userlevel 4
Badge +6

Hey @NotAlex ,

 

Glad that this is now resoled! Updating must have fixed the issue, let us know if anything else comes up! 

Reply