Deleting a product does not work

  • 30 September 2021
  • 1 reply

Badge +2

I have two iOS products in my app.

One I do not want to use any longer so I deleted it from app store connect.

Next step is to delete it from the products in my app in revenuecat. So I click “Products”, then select the product from the list and on the bottom of the page I click the big red “Delete product” button.

Then press “Confirm” on the “Are you sure?” warning.

Result: Product still there….

Tried this in Safari and Firefox.

Any clues?

I think this may also be the cause of the WARN: 🍎‼️ Could not find SKProduct for ( that I keep getting when I try to test it on my actual device. The products that I have in Revenuecat do not match the products that I have in the app store. I tried re-adding the product to the app store but apple won’t let me do that because I already used it previously.


Edit: I just tried it again and then I noticed the brief popup on the top of the screen with the text: “There are transactions in the system using this product.” I’m not sure what this means yet but I’m going to look for a solution.


Edit2: Ok I was able to go the “Recent transactions” and delete the user (me) from the sandbox that purchased that product. Then I could delete it. The product is now deleted but I still have the SKProduct error that I cannot find the cause for. I checked for a mismatch with app store connect and it all looks the same.
Also followed this: 



Best answer by PaulB 30 September 2021, 11:02

View original

1 reply

Badge +2

Solved! :grinning:

After reading this post again I found this:

  1. If you're trying to fetch products from the App Store, ensure you're not using a StoreKit Configuration file 

So it turns out I was…. I removed the StoreKit configuration file from my scheme in Xcode and now it works. See apple documentation here for details: