Question

There was a problem with the store


Badge +2

There was a problem with the store.
at node_modules\react-native\Libraries\BatchedBridge\NativeModules.js:null in promiseMethodWrapper
at node_modules\react-native-purchases\dist\purchases.js:null in __generator$argument_1
at node_modules\react-native-purchases\dist\purchases.js:null in step
at node_modules\react-native-purchases\dist\purchases.js:null in fulfilled
at node_modules\react-native\node_modules\promise\setimmediate\core.js:null in tryCallOne
at node_modules\react-native\node_modules\promise\setimmediate\core.js:null in setImmediate$argument_0
at node_modules\react-native\Libraries\Core\Timers\JSTimers.js:null in _allocateCallback$argument_0
at node_modules\react-native\Libraries\Core\Timers\JSTimers.js:null in _callTimer
at node_modules\react-native\Libraries\Core\Timers\JSTimers.js:null in _callReactNativeMicrotasksPass
at node_modules\react-native\Libraries\Core\Timers\JSTimers.js:null in callReactNativeMicrotasks
at node_modules\react-native\Libraries\BatchedBridge\MessageQueue.js:null in __callReactNativeMicrotasks
at node_modules\react-native\Libraries\BatchedBridge\MessageQueue.js:null in __guard$argument_0
at node_modules\react-native\Libraries\BatchedBridge\MessageQueue.js:null in __guard
at node_modules\react-native\Libraries\BatchedBridge\MessageQueue.js:null in flushedQueue

 

 

 

Thats the complete error: and here is my code:

 const awaitPurchases= () =>{

  Purchases.setDebugLogsEnabled(true)

  if(Platform.OS === 'android'){

    Purchases.configure({apiKey: apikeyRevCat})

  }

 }

 useEffect(() =>{

  awaitPurchases()

 },[])

 

And then in another screen:

   const fetchOfferings= async () =>{

    try{

      const offerings= await Purchases.getOfferings()

      console.log(offerings)

    }catch(e){

      console.log(e)

    }

   }

 

useEffect(()=>{

 fetchOfferings()

 

},[])


12 replies

Userlevel 5
Badge +7

Hi @majestic_ , like said before, in cases like this it is best to contact our support team directly who might be able to help debug: http://revenuecat.com/support

Badge +3

Also facing the same issues from real users. During sandbox testing everything works.
 

Userlevel 5
Badge +7

Hey @Justo Mateos , I would recommend getting in touch with our support team directly who might be able to help debug: http://revenuecat.com/support

Badge +2

As per the troubleshooting guide, the error SERVICE_UNAVAILABLE points to issues with the network connection. So other than waiting to see if it resolves itself, it might be good to check on a different network (e.g., Wifi vs. cellular) and/or check firewall settings.

Hey Jens, hope you are doing well, there have been more than 2 days but I keep getting the same error, do you know what else could be happening? 

Badge +3

We are currently running into this as well, although we are getting the dreaded “SKErrorDomain” error.  We were successfully testing purchases in Test Flight, until mid afternoon yesterday and then all purchases began to fail.  Right before we were going to submit for App Review. Tried creating new Sandbox Users.  No matter what we get the same error:

{"code":"2","message":"There was a problem with the App Store.","domain":"RCPurchasesErrorDomain","userInfo":{"readable_error_code":"STORE_PROBLEM","readableErrorCode":"STORE_PROBLEM","NSLocalizedDescription":"There was a problem with the App Store.","NSUnderlyingError":{"code":"0","message":"underlying error","domain":"SKErrorDomain","userInfo":{"NSUnderlyingError":{"code":"500","message":"underlying error","domain":"ASDErrorDomain","userInfo":{"NSLocalizedFailureReason":"An unknown error occurred","NSUnderlyingError":{"code":"301","message":"underlying error","domain":"AMSErrorDomain","userInfo":{"NSLocalizedDescription":"Invalid Status Code","AMSStatusCode":500,"AMSURL":"https://sandbox.itunes.apple.com/WebObjects/MZBuy.woa/wa/inAppBuy?REDACTED","NSLocalizedFailureReason":"The response has an invalid status code"}

 

Userlevel 5
Badge +7

As per the troubleshooting guide, the error SERVICE_UNAVAILABLE points to issues with the network connection. So other than waiting to see if it resolves itself, it might be good to check on a different network (e.g., Wifi vs. cellular) and/or check firewall settings.

Badge +2

I parsed the error and i get this:


{"nativeStackAndroid":[],"userInfo":{"underlyingErrorMessage":"Error when fetching products. DebugMessage: An internal error occurred.. ErrorCode: SERVICE_UNAVAILABLE.","readableErrorCode":"StoreProblemError","readable_error_code":"StoreProblemError","message":"There was a problem with the store.","code":2},"message":"There was a problem with the store.","code":"2","line":23572,"column":45,"sourceURL":"http://192.168.0.23:8081/node_modules/expo/AppEntry.bundle?platform=android&dev=true&minify=false&app=com.Decidite&modulesOnly=false&runModule=true"}

Badge +2

 

Thank you very much for you help Jens, i will check that underlying error

Userlevel 5
Badge +7

Have you checked what the underlying error is?.see here: https://community.revenuecat.com/sdks-51/unable-to-track-error-in-react-native-140?postid=258#post258 

Badge +2

Hello Jens, yes I have taken a look at that guide and did the things that say in that guide, but I still can't fix it

Userlevel 5
Badge +7

Have you had a look at this troubleshooting guide: https://community.revenuecat.com/featured-articles-55/what-does-the-error-there-was-a-problem-with-the-app-store-play-store-mean-480 

Badge +2

I tried everything and I can’t solve the issue

Reply