Ignoring purchase request for already subscribed package error when trying to repurchase a consumable

  • 19 April 2024
  • 6 replies

Userlevel 1
Badge +1

Hi there,

I am using Revenue Cat Paywalls to let my users purchase products. However if a consumable has been purchased before I am getting the error message:

  • Ignoring purchase request for already subscribed package

This is happening even though the purchase request is for a NON_RENEWING_PURCHASE which is not a subscription.

My app is written in Flutter and I am currently testing on Android before moving on to iOS. 

I have rechecked my product set up on the Google Play Store and they are not set up as subscriptions. These products are not set up with entitlements in RC, they only have offerings attached.

Can anyone help resolve this because at the moment my app doesn’t allow the repurchase of consumables which is obviously an issue.


6 replies

Userlevel 4
Badge +8


Happy to help here. Our SDK does consume all Android purchases by default, so this is unexpected. Can you confirm that you checked the “Multi-quanity” box in Google Play Console that allows the product to be purchased more than once?


Userlevel 1
Badge +1

Hi Ryan,

It wasn’t checked. But I have now checked it and tried again and it still comes back with the same error. Do I need to somehow reset it in Revenue Cat after making this change?

Userlevel 4
Badge +8

Hi @lawrence-e2e55c, sorry I was mistaken, that is specifically for multiple transactions/purchase event, not for multiple transactions across time.

Can you open a support ticket so we can get some more info/a screenshot of how the products are setup in Google Play Console?


Hi, I have exactly the same issue.

I am using Revenue Cat Paywalls to let my users purchase products. I have a subscription and a non-renewing consumable product set up. The consumable product is not linked to an entitlement. I can purchase it once, no issue. When I purchase it again, I get the error "Ignoring purchase request for already subscribed package”. I tested both options for the "multi quantity” box, with the same result.

Any updates for this issue?

Userlevel 1
Badge +1

I have raised a support ticket and its currently with Revenue Cat engineering. It’s been with them for a few weeks now with no solution yet. This is currently blocking my go live so its very frustrating.


I will update here if I find a solution. If you find a solution please let me know...

Userlevel 1
Badge +1

Further update, after a month I still have no update from the Revenue Cat engineering team which is quite frustrating.

However I have identified that this issue only affects Google Play and is not happening when I am testing on iOS using the simulator.