How to resolve Apple alert "You are not authorised to make purchases of this InApp in Sandbox at this time."?

  • 2 November 2022
  • 3 replies

Badge +2

 When attempting to purchase a product I’m receiving an alert from Apple that says "You are not authorised to make purchases of this InApp in Sandbox at this time." (image below). Has anyone encountered this before and has a solution?



3 replies

Userlevel 1
Badge +2

OK, I figured out my problem, and it was a little obscure, but I’ll post it just in case there are other developers in the same boat.

I have two Apple Developer Program accounts. I had one as an individual, and then created a new one for my company.  Apparently, when I thought I was creating new sandbox users for my company account, I was actually adding them to my individual account.  With all the logging in, logging out, verifying new accounts, etc., it’s easy to get confused as to who is logged in where.

Once I figured it out and added new sandbox users to the company account, things worked as expected.

I’m still not sure how to unsubscribe/cancel for purposes of testing, but at least I can test purchases now.

Userlevel 1
Badge +2

I am signed in to my phone as a Sandbox user and I continue to get this message.  I have signed out, created new sandbox users, signed back in, and I keep getting this same message.  It says, “You can change account permissions in App Store Connect,” but there does not seem to be any place in App Store Connect to do this.  If there is, it’s very well hidden.

I was able to make a successful test purchase once, with my first sandbox user, but I couldn’t find a way to unsubscribe that user so that I could try it again. After that, I started making new sandbox users but I was never able to make a successful purchase with any of those. Just kept running into this error message.

I’m pretty much stuck now.

Userlevel 4
Badge +6

Hey @revive,

This error can crop up if you don’t have test users configured. Are you currently logged into a sandbox test account on your device? See more about how to create a test user and then add the account to your device here in our docs: