Question

Empty products after enabling new 'Base price' feature in App Store Connect

  • 10 March 2023
  • 7 replies
  • 356 views

Badge +5

After receiving an email from Apple about their new ‘Base price’ functionality for In App products I have adopted prices accordingly and set the base prices. However...

Now ‘getOfferingsWithCompletion’ no longer delivers those products to my app in Sandbox mode, but it (still) does in Production mode at the moment. I have not changed any IDs, all contracts are signed, I checked that everything is fine, but still no luck.

All I have changed in App Store Connect is: enabled Base Price functionality for the products, adopted prices accordingly. Absolutely no other changes, neither in my code, nor on App Store Connect.

Anybody else seeing this? Any help is much appreciated.

Console output:

2023-03-10 14:02:20.935490+0100 my3E[16682:3200389] [Purchases] - DEBUG: ℹ️ No existing products cached, starting store products request for: ["my3e_tip_2", "my3e_hide_nag", "my3e_01months_ar_nfs", "my3e_12months_ar", "my3e_tip_1", "my3e_12months_ar_nfs", "my3e_tip_4", "my3e_tip_3", "my3e_01week_ar_nfs", "my3e_01months_ar"]

2023-03-10 14:02:20.935832+0100 my3E[16682:3200383] [Purchases] - DEBUG: ℹ️ No existing products cached, starting store products request for: ["my3e_tip_2", "my3e_hide_nag", "my3e_01months_ar_nfs", "my3e_12months_ar", "my3e_tip_1", "my3e_12months_ar_nfs", "my3e_tip_4", "my3e_tip_3", "my3e_01week_ar_nfs", "my3e_01months_ar"]

2023-03-10 14:02:20.935870+0100 my3E[16682:3200389] [Purchases] - DEBUG: ℹ️ Found an existing request for products: ["my3e_01months_ar", "my3e_tip_2", "my3e_hide_nag", "my3e_12months_ar_nfs", "my3e_tip_1", "my3e_01months_ar_nfs", "my3e_tip_3", "my3e_tip_4", "my3e_12months_ar", "my3e_01week_ar_nfs"], appending to completion

2023-03-10 14:02:20.936039+0100 my3E[16682:3200389] [Purchases] - DEBUG: ℹ️ Found an existing request for products: ["my3e_12months_ar_nfs", "my3e_hide_nag", "my3e_12months_ar", "my3e_tip_1", "my3e_tip_3", "my3e_tip_4", "my3e_01months_ar_nfs", "my3e_01months_ar", "my3e_01week_ar_nfs", "my3e_tip_2"], appending to completion

2023-03-10 14:02:20.936110+0100 my3E[16682:3200389] [Purchases] - DEBUG: ℹ️ GetOfferingsOperation: Finished

2023-03-10 14:02:20.936259+0100 my3E[16682:3200389] [Purchases] - DEBUG: ℹ️ Serial request done: GET subscribers/31135E-7E5355/offerings, 0 requests left in the queue

2023-03-10 14:02:20.999166+0100 my3E[16682:3200383] [Purchases] - DEBUG: 😻 Store products request finished

2023-03-10 14:02:20.999166+0100 my3E[16682:3200390] [Purchases] - DEBUG: 😻 Store products request request received response

2023-03-10 14:02:21.000572+0100 my3E[16682:3200390] [Purchases] - WARN: 🍎‼️ Could not find products with identifiers: ["my3e_tip_1", "my3e_tip_4", "my3e_tip_2", "my3e_tip_3", "my3e_hide_nag"].

There is a problem with your configuration in App Store Connect.

More info here: https://errors.rev.cat/configuring-products

2023-03-10 14:02:21.001040+0100 my3E[16682:3200390] [Purchases] - WARN: ⚠️ There's a problem with your configuration. No packages could be found for offering with  identifier tips. This could be due to Products not being configured correctly in the RevenueCat dashboard, App Store Connect (or the StoreKit Configuration file if one is being used).

To configure products, follow the instructions in https://rev.cat/how-to-configure-offerings.

More information: https://rev.cat/why-are-offerings-empty

2023-03-10 14:02:21.001095+0100 my3E[16682:3200390] [Purchases] - WARN: ⚠️ There's a problem with your configuration. No packages could be found for offering with  identifier disable_nag. This could be due to Products not being configured correctly in the RevenueCat dashboard, App Store Connect (or the StoreKit Configuration file if one is being used).

To configure products, follow the instructions in https://rev.cat/how-to-configure-offerings.

More information: https://rev.cat/why-are-offerings-empty

2023-03-10 14:02:21.001227+0100 my3E[16682:3200390] [Purchases] - WARN: 🍎‼️ Could not find products with identifiers: ["my3e_tip_4", "my3e_tip_1", "my3e_tip_3", "my3e_hide_nag", "my3e_tip_2"].

There is a problem with your configuration in App Store Connect.

More info here: https://errors.rev.cat/configuring-products

2023-03-10 14:02:21.001280+0100 my3E[16682:3200390] [Purchases] - WARN: ⚠️ There's a problem with your configuration. No packages could be found for offering with  identifier tips. This could be due to Products not being configured correctly in the RevenueCat dashboard, App Store Connect (or the StoreKit Configuration file if one is being used).

To configure products, follow the instructions in https://rev.cat/how-to-configure-offerings.

More information: https://rev.cat/why-are-offerings-empty

2023-03-10 14:02:21.001321+0100 my3E[16682:3200390] [Purchases] - WARN: ⚠️ There's a problem with your configuration. No packages could be found for offering with  identifier disable_nag. This could be due to Products not being configured correctly in the RevenueCat dashboard, App Store Connect (or the StoreKit Configuration file if one is being used).


7 replies

Badge +5

Problem is partly solved (products are delivered via Sandbox), but now purchases fail with a new error:

https://developer.apple.com/forums/thread/726675

Badge +5

It looks like the problem is in fact related to the base price functionality:

https://developer.apple.com/forums/thread/726252?answerId=747406022#747406022

You didn’t find a workaround so far either right? 

I am note sure, but it might help to set the base price back to USD. But I never tried that myself.

Badge +2

It looks like the problem is in fact related to the base price functionality:

https://developer.apple.com/forums/thread/726252?answerId=747406022#747406022

You didn’t find a workaround so far either right? 

Badge +2

I think I have the same issue https://community.revenuecat.com/general-questions-7/i-can-t-get-iap-only-subscriptions-2667

Badge +5

It looks like the problem is in fact related to the base price functionality:

https://developer.apple.com/forums/thread/726252?answerId=747406022#747406022

Badge +2

I’m currently in the process of setting up IAP on iOS. Last week I could still test in my debug mode on my phone, now I get the same error. I had deleted all the products I created and created new ones, they are ‘Ready for Submit’, but the sdk in my flutter app doesn’t find them on iOS: 

 

Purchases] - DEBUG: ℹ️ No existing products cached, starting store products request for: ["yg084md"]

[Default] [StoreKit] Did not receive any products or error for products request.

[Purchases] - DEBUG: 😻 Store products request request received response

Badge +5

Update: this might be related to this:

https://developer.apple.com/forums/thread/726252?answerId=747378022#747378022

and it's probably just a coincidence with my base price changes...

Reply