Question

EAS build error

  • 21 September 2022
  • 0 replies
  • 12 views

Badge

I added the react-native-purchases package of my react native project. When i run eas build it fails with the following error:

 (ios/Pods/RevenueCat/Sources/Identity/CustomerInfoManager.swift:192:29)

190 |
191 | @available(iOS 13.0, macOS 10.15, tvOS 13.0, watchOS 6.2, *)
> 192 | var customerInfoStream: AsyncStream<CustomerInfo> {
| ^ 'AsyncStream' is only available in iOS 15.0 or newer
193 | return AsyncStream(bufferingPolicy: .bufferingNewest(1)) { continuation in
194 | if let lastSentCustomerInfo = self.lastSentCustomerInfo {
195 | continuation.yield(lastSentCustomerInfo)

 


0 replies

Be the first to reply!

Reply