Question

Compatibility with Tauri v2

  • 29 April 2024
  • 3 replies
  • 81 views

Badge

Hello, since Tauri v2 now builds iOS/Android apps, and it doesn’t have any In App Purchase support/plugin, it’s possible to implement RevenueCat in Tauri?

 

 


This post has been closed for comments

3 replies

Userlevel 4
Badge +8

At this time we do not have plans to support Tauri v2 but I have passed this feedback along to the team.

Badge

Hi, we don't have sdk support for Tauri specifically, but you could always use our api endpoints to achieve the same functionality.

Hello, thank you for your reply. 

I don’t have clear if the API shows, for example, the proprietary OS purchase interface, and if it compliments the Apple guidelines specially.

I’ve seen a workaround for iOS that could be, use a Rust crate that executes Swift code server side, and try to use the Apple SDK directly (I would have to ask to the Tauri team for this step).

Do you know if at any point RevenueCat will support Tauri v2? Since the Flutter employee layoffs, I think a lot of people will move the mobile development into Tauri. And since Tauri itself doesn’t provides any in app purchase option, the first in appear, the first will get the developer’s eye.

Thank you and regards.

Userlevel 4
Badge +8

Hi, we don't have sdk support for Tauri specifically, but you could always use our api endpoints to achieve the same functionality.