Question

RevenueCat requires Xcode 13.2 with Swift 5.5.2 to compile.

  • 5 April 2023
  • 3 replies
  • 159 views

Badge +1

I’m using revenueCat in my flutter project, when building my app in Xcode it throw this exception:

RevenueCat requires Xcode 13.2 with Swift 5.5.2 to compile.

 

installed Xcode version: Version 14.2 (14C18)
swift --version:
swift-driver version: 1.62.15 Apple Swift version 5.7.2 (swiftlang-5.7.2.135.5 clang-1400.0.29.51)
Target: x86_64-apple-macosx12.0

any help?


3 replies

Userlevel 3
Badge +7

Hi,

Sorry you are having difficulty here. If you are still having this issue, here are some ideas of how to resolve this,

  1. Clean your build folder in Xcode.
  2. Quit Xcode and clear derived data.
  3. Update CocoaPods to the latest version and update your repository.
  4. Update the RevenueCat pod in your project directory.
  5. Open your project's .xcworkspace file in Xcode (not the .xcodeproj file).
  6. Verify the Swift version in your project's target settings, making sure it matches the installed version or uses the compiler default.
  7. Build your project again in Xcode.

If it still doesn’t work, please open a ticket in our dashboard. You can submit a ticket here: https://app.revenuecat.com/settings/support

 

Badge +1

Thank you for your replay, sorry for my late response.

Actually, I have reinstall Mac OS, Xcode and CocoaPods from the beginning, but still having the same issue.

How to update RevenueCat pod in my project directory?

 

The Swift version in my project's target settings is:

 

Badge +1

I found the solution, I was previously specifying the Swift version in the pod file to be 4.2 and I forgot to comment it after updating Flutter, sorry for not paying attention to this before I posted the problem.

 

 

Reply